summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-07 15:54:50 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-07 20:55:24 +0100
commitb40bd26252b6753af9dbb95d4fc033c8d56bf191 (patch)
treeb28949e8a7b0e27d05f373c785236a1bb1c47660 /configure.ac
parent08d2fd4a122cbcab1d1a179471d146ac6c4b5f66 (diff)
downloadrasdaman-upstream-b40bd26252b6753af9dbb95d4fc033c8d56bf191.tar.gz
rasdaman-upstream-b40bd26252b6753af9dbb95d4fc033c8d56bf191.tar.xz
rasdaman-upstream-b40bd26252b6753af9dbb95d4fc033c8d56bf191.zip
install: Use custom subdir for libs, data, headers
Redefine $(pkgdatadir), $(pkgincludedir) and $(pkglibdir) in order to make the subdir component configurable with the RDM_SUBDIR variable. Then install all libraries and include files to the package specific subdirectories, as their names are far too generic to allow general system wide installation, such as e.g. "bool.h" or "libnetwork.a". Move some very custom and non-general scripts (some with generic names) to a new $(pkglibdir)/bin/ subdir.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index adc954d..955d535 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,16 @@ AM_INIT_AUTOMAKE()
# Define CXXFLAGS before AC_PROG_CXX or it will automatically add -g -O2 on some systems
CXXFLAGS=
GCJFLAGS=
+
+# rasdaman specific subdirectory component to install in
+AC_ARG_VAR([RDM_SUBDIR],
+ [subdirectory component to install in, e.g. rasdaman8 or rasdaman])
+AS_IF([test "x$RDM_SUBDIR" = "x"],
+ [RDM_SUBDIR="\${PACKAGE}"])
+AC_SUBST([RDM_SUBDIR])
+AC_MSG_CHECKING([install subdirectory name])
+AC_MSG_RESULT([$RDM_SUBDIR])
+
# Checks for programs.
AC_PROG_CXX
AC_PROG_AWK
@@ -231,7 +241,7 @@ AC_ARG_WITH([logdir],
[AS_HELP_STRING([--with-logdir=PATH],
[the path where the servers will store their logs])],
[logdir="$withval"],
- [logdir="\${localstatedir}/log/\${PACKAGE}"])
+ [logdir="\${localstatedir}/log/\${RDM_SUBDIR}"])
# --------------- Database Specific Configuration ------------------
####################################################################
@@ -317,6 +327,14 @@ AC_DEFINE_UNQUOTED([COMPDATE], ["$COMPDATE"])
CXXFLAGS+=" -I$abs_top_srcdir -I$abs_top_srcdir/debug -I$abs_top_srcdir/include"
+# Our special install locations
+AC_SUBST([pkgdatadir], ["\${datadir}/\${RDM_SUBDIR}"])
+AC_SUBST([pkglibdir], ["\${libdir}/\${RDM_SUBDIR}"])
+AC_SUBST([pkgincludedir], ["\${includedir}/\${RDM_SUBDIR}"])
+# The "exec" part of the name is important for automake to include
+# this in install-exec instead of install-data.
+AC_SUBST([rdmexecbindir], ["\${pkglibdir}/bin"])
+
# --------------- System Test Settings -----------------------------
####################################################################