summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-05 14:21:24 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-07 20:57:37 +0100
commit8f2566c5a39f758bb0db337fc106fa94f52220df (patch)
tree47107416f6164458434a5a934bebb98741c215d1 /configure.ac
parentfef5564a64870ce438d0b1185df521fd54126171 (diff)
downloadrasdaman-upstream-8f2566c5a39f758bb0db337fc106fa94f52220df.tar.gz
rasdaman-upstream-8f2566c5a39f758bb0db337fc106fa94f52220df.tar.xz
rasdaman-upstream-8f2566c5a39f758bb0db337fc106fa94f52220df.zip
build: Support (srcdir != builddir) VDIR builds
Support (srcdir != builddir) VDIR builds. This will also help a lot with preparing for a working "make distcheck".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 59f3601..04d3805 100644
--- a/configure.ac
+++ b/configure.ac
@@ -279,7 +279,7 @@ AS_IF([test "$with_default_basedb" == postgresql],
# TODO: change main to something sensible
AC_CHECK_LIB([pq], [main], , [AC_MSG_FAILURE([Library not found! Please install...])])
AC_CHECK_LIB([pgtypes], [main], , [AC_MSG_FAILURE([Library not found! Please install...])])
- EMBEDDEDSQLPRECOMPILER="$ECPG -o"
+ EMBEDDEDSQLPRECOMPILER="\$(ECPG)"
BASEDBSTRING=pgsql
],
[AC_MSG_ERROR([unsupported base DBMS: $with_default_basedb])])
@@ -335,7 +335,8 @@ LDFLAGS=""
COMPDATE=`date +"%d.%m.%Y %H:%M:%S"`
AC_DEFINE_UNQUOTED([COMPDATE], ["$COMPDATE"])
-AM_CPPFLAGS+=" -I$abs_top_srcdir -I$abs_top_srcdir/debug -I$abs_top_srcdir/include"
+AM_CPPFLAGS+=" -I\${top_builddir}"
+AM_CPPFLAGS+=" -I\${top_srcdir} -I\${top_srcdir}/debug -I\${top_srcdir}/include"
# Our special install locations
AC_SUBST([pkgdatadir], ["\${datadir}/\${RDM_SUBDIR}"])