summaryrefslogtreecommitdiffstats
path: root/bin/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-05 14:21:24 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-07 20:57:37 +0100
commit8f2566c5a39f758bb0db337fc106fa94f52220df (patch)
tree47107416f6164458434a5a934bebb98741c215d1 /bin/Makefile.am
parentfef5564a64870ce438d0b1185df521fd54126171 (diff)
downloadrasdaman-upstream-8f2566c5a39f758bb0db337fc106fa94f52220df.tar.gz
rasdaman-upstream-8f2566c5a39f758bb0db337fc106fa94f52220df.tar.xz
rasdaman-upstream-8f2566c5a39f758bb0db337fc106fa94f52220df.zip
build: Support (srcdir != builddir) VDIR builds
Support (srcdir != builddir) VDIR builds. This will also help a lot with preparing for a working "make distcheck".
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index 72a45fe..348a4b2 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -35,7 +35,7 @@ script_edit = $(SED) \
start_rasdaman.sh stop_rasdaman.sh create_db.sh: Makefile
rm -f $@
- $(script_edit) '$@.in' >$@
+ $(script_edit) "$(srcdir)/$$(basename "$@").in" >$@
chmod +x $@
chmod a-w $@
@@ -44,4 +44,4 @@ stop_rasdaman.sh: stop_rasdaman.sh.in
create_db.sh: create_db.sh.in
rasmgr.conf: rasmgr.conf.in Makefile
rm -f $@
- $(SED) -e "s|@hostname[@]|`hostname`|g" '$@.in' >$@
+ $(SED) -e "s|@hostname[@]|`hostname`|g" "$(srcdir)/$$(basename "$@").in" >$@