summaryrefslogtreecommitdiffstats
path: root/bin/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-06 16:46:17 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-07 20:57:50 +0100
commit02bf6022d153b9abeb513b0055510559f873da93 (patch)
tree5f9077b13de0a0676010ae9a57254276f36282f6 /bin/Makefile.am
parent5e7d86502db944b9b9b9f51c72822e3b0e45f215 (diff)
downloadrasdaman-upstream-02bf6022d153b9abeb513b0055510559f873da93.tar.gz
rasdaman-upstream-02bf6022d153b9abeb513b0055510559f873da93.tar.xz
rasdaman-upstream-02bf6022d153b9abeb513b0055510559f873da93.zip
nonrec-build: Rename Makefile.am to Makefile-files
We will keep only three Makefile.am: * $(top_srcdir) * manuals_and_examples/ (needs code to be generated first) * systemtest/ (needs everything to be built)
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
deleted file mode 100644
index 348a4b2..0000000
--- a/bin/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# This file is part of rasdaman community.
-#
-# Rasdaman community is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# Rasdaman community is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with rasdaman community. If not, see <http://www.gnu.org/licenses/>.
-#
-# Copyright 2003, 2004, 2005, 2006, 2007, 2008, 2009 Peter Baumann /
-# rasdaman GmbH.
-#
-# For more information please see <http://www.rasdaman.org>
-# or contact Peter Baumann via <baumann@rasdaman.com>.
-#
-###################################################################
-
-rdmexecbin_SCRIPTS = start_rasdaman.sh stop_rasdaman.sh create_db.sh
-EXTRA_DIST = stop_rasdaman.sh.in start_rasdaman.sh.in create_db.sh.in rasmgr.conf.in
-CLEANFILES = start_rasdaman.sh stop_rasdaman.sh create_db.sh rasmgr.conf
-dist_sysconf_DATA=rasmgr.conf
-dist_pkgdata_DATA=errtxts_en errtxts_de errtxts_fr errtxts
-
-script_edit = $(SED) \
- -e 's|@logdir[@]|$(logdir)/|g' \
- -e 's|@bindir[@]|$(bindir)/|g' \
- -e 's|@pkgdatadir[@]|$(pkgdatadir)/|g'
-
-start_rasdaman.sh stop_rasdaman.sh create_db.sh: Makefile
- rm -f $@
- $(script_edit) "$(srcdir)/$$(basename "$@").in" >$@
- chmod +x $@
- chmod a-w $@
-
-start_rasdaman.sh: start_rasdaman.sh.in
-stop_rasdaman.sh: stop_rasdaman.sh.in
-create_db.sh: create_db.sh.in
-rasmgr.conf: rasmgr.conf.in Makefile
- rm -f $@
- $(SED) -e "s|@hostname[@]|`hostname`|g" "$(srcdir)/$$(basename "$@").in" >$@