summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-05 14:18:25 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2011-03-07 20:57:37 +0100
commitfef5564a64870ce438d0b1185df521fd54126171 (patch)
tree1bb7f08dbbb9d954cdf416ac9b7015c460ffaa37 /Makefile.am
parentd261ea3db63beaf5581c46afcb6c7e297a8010fb (diff)
downloadrasdaman-upstream-fef5564a64870ce438d0b1185df521fd54126171.tar.gz
rasdaman-upstream-fef5564a64870ce438d0b1185df521fd54126171.tar.xz
rasdaman-upstream-fef5564a64870ce438d0b1185df521fd54126171.zip
build: Change dubious wildcard stuff to use +=
Also make sure that the list of files is updated on "make dist".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 22 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e2565ec..c624c8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,9 +32,28 @@
ACLOCAL_AMFLAGS = -I m4
-nobase_pkginclude_HEADERS=raslib/*.h raslib/*.hh raslib/*.icc raslib/*.cc \
- rasodmg/*.hh rasodmg/*.cc rasodmg/*.icc conversion/*.h conversion/*.hh \
- compression/*.hh clientcomm/*.h clientcomm/*.hh
+nobase_pkginclude_HEADERS =
+include $(srcdir)/header-files.mk
+
+dist-hook:
+ (echo "# DO NOT MODIFY THIS FILE"; \
+ echo "# This file was autogenerated by the dist-hook target"; \
+ cd "$(srcdir)"; \
+ find raslib -type f \
+ \( -name '*.h' -or -name '*.hh' -or -name '*.icc' -or -name '*.cc' \) ; \
+ find rasodmg -type f \
+ \( -name '*.hh' -or -name '*.cc' -or -name '*.icc' \) ; \
+ find conversion -type f \( -name '*.h' -or -name '*.hh' \) ; \
+ find compression -type f -name '*.hh' ; \
+ find clientcomm -type f \( -name '*.h' -or -name '*.hh' \) \
+ ) | $(SED) 's,^\([^#]\),nobase_pkginclude_HEADERS += \1,' \
+ > header-files.mk.new
+ if test -f "$(srcdir)/header-files.mk" \
+ && cmp "header-files.mk.new" "$(srcdir)/header-files.mk"; then \
+ rm -f "header-files.mk.new"; \
+ else \
+ mv -f "header-files.mk.new" "$(srcdir)/header-files.mk"; \
+ fi
SUBDIRS = relblobif relindexif relmddif relcatalogif reladminif relstorageif \
indexmgr catalogmgr tilemgr storagemgr compression commline network \