summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 506ad96..79d03a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,6 +80,13 @@ ppc-koji: $(srcdir)/src/secondary-koji
install -p -m 755 -T $(srcdir)/src/secondary-koji ppc-koji
if HAVE_PYTHON
+check-local: check-local-fedpkg-tests
+check-local-fedpkg-tests:
+ cd $(srcdir)/src \
+ && python "pyfedpkg/tests.py" python "$$PWD/fedpkg.py" -v
+endif
+
+if HAVE_PYTHON
CLEANFILES += fedpkg.1
man1_MANS = fedpkg.1
fedpkg.1: fedpkg