summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorChris Lumens <clumens@redhat.com>2010-06-21 13:56:12 -0400
committerChris Lumens <clumens@redhat.com>2010-06-21 15:02:19 -0400
commitb6434ef1d79d25786027f14c217088b880555491 (patch)
treef7bc57648f606697dc1b22bc2176d1757c23b7b5 /tests/Makefile.am
parent8b6978a084410b6ea91008cbc97d6b00af834761 (diff)
downloadanaconda-b6434ef1d79d25786027f14c217088b880555491.tar.gz
anaconda-b6434ef1d79d25786027f14c217088b880555491.tar.xz
anaconda-b6434ef1d79d25786027f14c217088b880555491.zip
Fix test suite Makefile.am files.
(1) Many tests have moved from foo.py to foo_test.py, so that needs changing in the TESTS variable. (2) Add a $PATH that includes /sbin and /usr/sbin so losetup and storage commands work. (3) Change PYTHONPATH to include new pyanaconda directory.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ee05e4815..147c551dd 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,3 +20,7 @@
SUBDIRS = mock kickstart_test storage_test regex
MAINTAINERCLEANFILES = Makefile.in
+
+TESTS_ENVIRONMENT = PATH=/sbin:/usr/sbin:$$PATH PYTHONPATH=$(top_builddir)/tests:$(top_builddir)/isys/.libs:$(top_builddir)/isys:$(top_builddir)/pyanaconda
+
+TESTS = fw_test.py