summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Lumens <clumens@redhat.com>2010-04-14 17:19:52 -0400
committerChris Lumens <clumens@redhat.com>2010-04-15 10:29:06 -0400
commit740b8e76f35692a01007e2e707173a44b7d4e1e2 (patch)
tree538928d6c3192ed70593d2f94b9ad14e0b9854d7 /Makefile.am
parent5a7dffc22917fdb9a5a8791660fc4279973da895 (diff)
downloadanaconda-740b8e76f35692a01007e2e707173a44b7d4e1e2.tar.gz
anaconda-740b8e76f35692a01007e2e707173a44b7d4e1e2.tar.xz
anaconda-740b8e76f35692a01007e2e707173a44b7d4e1e2.zip
pylint up, pychecker down.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 2 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index c1c6e08a6..c9955c69d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,8 +23,8 @@ SUBDIRS = isys po loader booty storage textw utils scripts bootdisk \
installclasses iw command-stubs ui docs pixmaps tests fonts \
gptsync liveinst
-EXTRA_DIST = config.rpath COPYING pychecker-false-positives \
- pycheckrc-for-anaconda runpychecker.sh lang-table \
+EXTRA_DIST = config.rpath COPYING \
+ lang-table \
anaconda.spec.in
MAINTAINERCLEANFILES = Makefile.in config.guess config.h.in config.sub \
@@ -58,8 +58,6 @@ xutils_la_SOURCES = xutils.c
anacondadir = $(pkgpyexecdir)
anaconda_PYTHON = *.py
-PYCHECKERPATH = isys:textw:iw:installclasses:/usr/share/system-config-date
-PYCHECKEROPTS = -F pycheckrc-for-anaconda
ARCHIVE_TAG = $(PACKAGE_NAME)-$(PACKAGE_VERSION)-$(PACKAGE_RELEASE)
sed_verbose = $(sed_verbose_$(V))
@@ -97,12 +95,6 @@ src: archive
@rpmbuild -ts --nodeps $(PACKAGE_NAME)-$(PACKAGE_VERSION).tar.bz2 || exit 1
@rm -f $(PACKAGE_NAME)-$(PACKAGE_VERSION).tar.bz2
-pycheck:
- PYTHONPATH=$(PYCHECKERPATH) pychecker $(PYCHECKEROPTS) *.py textw/*.py iw/*.py installclasses/*.py storage/*.py | grep -v "__init__() not called"
-
-pycheck-file:
- PYTHONPATH=.:$(PYCHECKERPATH) pychecker $(PYCHECKEROPTS) $(CHECK) | grep -v "__init__() not called"
-
api:
doxygen docs/api.cfg