summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2011-03-09 04:46:33 -1000
committerDavid Cantrell <dcantrell@redhat.com>2011-04-04 14:33:24 -1000
commit1979d4fedddb312172b186411c575e5c7b30f4fb (patch)
treef697e00e61983d46325ac1d7ec61c5257765e63f /Makefile.am
parent4f0dc0679223ae32fb56f180ba19f81a13e30206 (diff)
downloadanaconda-1979d4fedddb312172b186411c575e5c7b30f4fb.tar.gz
anaconda-1979d4fedddb312172b186411c575e5c7b30f4fb.tar.xz
anaconda-1979d4fedddb312172b186411c575e5c7b30f4fb.zip
Update Makefile.am to work with new translation system.
The po files are no longer stored in our repo. Get them from Transifex.net using 'tx'. Push updated anaconda.pot with tx each time we generate a new one at release time.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 14 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index ed8031ace..f18bdedaa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,6 +43,9 @@ sed_verbose = $(sed_verbose_$(V))
sed_verbose_ = $(sed_verbose_$(AM_DEFAULT_VERBOSITY))
sed_verbose_0 = @echo " SED "$@;
+TX_PULL_ARGS = -a --disable-overwrite
+TX_PUSH_ARGS = -s
+
$(PACKAGE_NAME).spec: $(PACKAGE_NAME).spec.in
$(sed_verbose)sed -e 's/#VERSION#/$(PACKAGE_VERSION)/' < $< > $@
@@ -56,14 +59,17 @@ tag:
@git tag -s -a -m "Tag as $(ARCHIVE_TAG)" $(ARCHIVE_TAG)
@echo "Tagged as $(ARCHIVE_TAG)"
-scratch:
+po-pull:
+ rm -f po/en@boldquot.gmo po/en@boldquot.po
+ rm -f po/en@quot.gmo po/en@quot.po
+ tx pull $(TX_PULL_ARGS)
+
+scratch: po-pull
$(MAKE) ARCHIVE_TAG=HEAD dist
+ git checkout -- po/$(PACKAGE_NAME).pot
archive:
- $(MAKE) tag
- $(MAKE) dist
- git checkout -- po/$(PACKAGE_NAME).pot
- ( cd po ; for f in *.po ; do git checkout -- $$f 2>/dev/null ; done )
+ $(MAKE) dist && $(MAKE) tag && git checkout -- po/$(PACKAGE_NAME).pot
release: archive
@@ -74,7 +80,7 @@ src: archive
api:
doxygen docs/api.cfg
-bumpver:
+bumpver: po-pull
@opts="-n $(PACKAGE_NAME) -v $(PACKAGE_VERSION) -r $(PACKAGE_RELEASE) -b $(PACKAGE_BUGREPORT)" ; \
if [ ! -z "$(IGNORE)" ]; then \
opts="$${opts} -i $(IGNORE)" ; \
@@ -83,7 +89,8 @@ bumpver:
opts="$${opts} -m $(MAP)" ; \
fi ; \
scripts/makebumpver $${opts} || exit 1 ; \
- $(MAKE) -C po $(PACKAGE_NAME).pot-update
+ $(MAKE) -C po $(PACKAGE_NAME).pot-update ; \
+ tx push $(TX_PUSH_ARGS)
install-buildrequires:
yum install $$(grep BuildRequires: anaconda.spec.in | cut -d ' ' -f 2)