summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2011-03-31 11:33:10 -1000
committerDavid Cantrell <dcantrell@redhat.com>2011-04-04 14:36:11 -1000
commit1590f811d577f6c8b7d73ee1ddaa22d70d3152e0 (patch)
treef795e1250fccf65f33b5b11070bc87b2b96a0747 /Makefile.am
parent9a0c3fc01d4aaf6bf2fdef02b221f3e39650ce27 (diff)
downloadanaconda-1590f811d577f6c8b7d73ee1ddaa22d70d3152e0.tar.gz
anaconda-1590f811d577f6c8b7d73ee1ddaa22d70d3152e0.tar.xz
anaconda-1590f811d577f6c8b7d73ee1ddaa22d70d3152e0.zip
Remove deprecated targets from top level Makefile.am
make testiso - We no longer have buildinstall make src - Did anyone ever use this? make archive - Use make release make archive-no-tag - Use make dist
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 1 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index f18bdedaa..a1a13cb89 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,12 +49,6 @@ TX_PUSH_ARGS = -s
$(PACKAGE_NAME).spec: $(PACKAGE_NAME).spec.in
$(sed_verbose)sed -e 's/#VERSION#/$(PACKAGE_VERSION)/' < $< > $@
-testiso: install
- @if [ "$(REPO)" = "" ]; then echo "ERROR: Need a repo to pull packages from!" ; exit 1 ; fi
- @pushd scripts ; sudo ./buildinstall --version $(PACKAGE_VERSION) --product $(PACKAGE_NAME) --release $(PACKAGE_NAME)-$(PACKAGE_VERSION) --output $(shell pwd)/outiso --updates $(DESTDIR) $(REPO) ; popd ; cp outiso/images/boot.iso ./boot.iso ; sudo rm -rf outiso
- @echo
- @echo "Test iso is located at ./boot.iso"
-
tag:
@git tag -s -a -m "Tag as $(ARCHIVE_TAG)" $(ARCHIVE_TAG)
@echo "Tagged as $(ARCHIVE_TAG)"
@@ -68,15 +62,9 @@ scratch: po-pull
$(MAKE) ARCHIVE_TAG=HEAD dist
git checkout -- po/$(PACKAGE_NAME).pot
-archive:
+release:
$(MAKE) dist && $(MAKE) tag && git checkout -- po/$(PACKAGE_NAME).pot
-release: archive
-
-src: archive
- @rpmbuild -ts --nodeps $(PACKAGE_NAME)-$(PACKAGE_VERSION).tar.bz2 || exit 1
- @rm -f $(PACKAGE_NAME)-$(PACKAGE_VERSION).tar.bz2
-
api:
doxygen docs/api.cfg
@@ -108,9 +96,6 @@ updates:
fi ; \
scripts/makeupdates $${opts}
-# DEPRECATED TARGETS:
-archive-no-tag: dist
-
# UNIT TESTING TARGETS
unittest:
PYTHONPATH=tests/:. nosetests --exclude=logpicker -a \!acceptance,\!slow tests/