summaryrefslogtreecommitdiffstats
path: root/src/Hooks/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Hooks/Makefile.am')
-rw-r--r--src/Hooks/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/Hooks/Makefile.am b/src/Hooks/Makefile.am
index eec2cd11..3c8aeb94 100644
--- a/src/Hooks/Makefile.am
+++ b/src/Hooks/Makefile.am
@@ -1,4 +1,4 @@
-libexec_PROGRAMS = abrt-hook-ccpp
+libexec_PROGRAMS = abrt-hook-ccpp abrt-hook-python
bin_PROGRAMS = dumpoops
# abrt-hook-ccpp
@@ -30,6 +30,18 @@ dumpoops_LDADD = \
../../lib/Utils/libABRTUtils.la \
../../lib/Utils/libABRTdUtils.la
+# abrt-hook-python
+abrt_hook_python_SOURCES = abrt-hook-python.cpp
+abrt_hook_python_CPPFLAGS = \
+ -I$(srcdir)/../../inc \
+ -I$(srcdir)/../../lib/Utils \
+ -DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
+ -DCONF_DIR=\"$(CONF_DIR)\" \
+ -DVAR_RUN=\"$(VAR_RUN)\" \
+ -D_GNU_SOURCE
+abrt_hook_python_LDADD = \
+ ../../lib/Utils/libABRTUtils.la
+
python_PYTHON = abrt.pth abrt_exception_handler.py
EXTRA_DIST = abrt_exception_handler.py.in $(man_MANS)