summaryrefslogtreecommitdiffstats
path: root/src/Daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Daemon/Makefile.am')
-rw-r--r--src/Daemon/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Daemon/Makefile.am b/src/Daemon/Makefile.am
index f4e5b77f..03c0c7d6 100644
--- a/src/Daemon/Makefile.am
+++ b/src/Daemon/Makefile.am
@@ -1,5 +1,8 @@
sbin_PROGRAMS = abrt
+# FIXME: we still link against dbus-c++ (not just dbus)
+# because lib/CommLayer links it in
+
abrt_SOURCES = \
ABRTPlugin.cpp ABRTPlugin.h \
PluginManager.cpp PluginManager.h \
@@ -21,12 +24,12 @@ abrt_CPPFLAGS = \
-DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
-DCONF_DIR=\"$(CONF_DIR)\" \
-DVAR_RUN=\"$(VAR_RUN)\" \
- $(GLIB_CFLAGS) $(DBUSCPP_CFLAGS) \
+ $(GLIB_CFLAGS) $(DBUS_CFLAGS) \
$(ENABLE_SOCKET_OR_DBUS)
abrt_LDADD = \
../../lib/MiddleWare/libABRTMiddleWare.la \
../../lib/CommLayer/libABRTCommLayer.la \
- $(DL_LIBS) $(DBUSCPP_LIBS) $(RPM_LIBS)
+ $(DL_LIBS) $(DBUS_LIBS) $(RPM_LIBS)
dbusabrtconfdir = ${sysconfdir}/dbus-1/system.d/
dist_dbusabrtconf_DATA = dbus-abrt.conf