summaryrefslogtreecommitdiffstats
path: root/src/Applet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Applet/Makefile.am')
-rw-r--r--src/Applet/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/Applet/Makefile.am b/src/Applet/Makefile.am
index 64a9ded4..6abef3bb 100644
--- a/src/Applet/Makefile.am
+++ b/src/Applet/Makefile.am
@@ -31,12 +31,13 @@ abrt_applet_LDADD = \
# $(DL_LIBS)
# $(GTK_LIBS)
-EXTRA_DIST = abrt-applet.desktop
-
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+@INTLTOOL_DESKTOP_RULE@
+
autostartdir = $(sysconfdir)/xdg/autostart
-autostart_DATA = abrt-applet.desktop
+autostart_in_files = abrt-applet.desktop.in
+
+autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
-abrt-applet.desktop:
- intltool-merge -d ../../po abrt-applet.desktop.in abrt-applet.desktop
+EXTRA_DIST = $(autostart_in_files)