summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8a0ab718..d1171732 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,14 @@ AC_ARG_ENABLE(debug,
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_PROG_CXX
-AC_PROG_YACC
+AC_CHECK_PROGS(YACC, 'bison -y', [no])
+[if test "$YACC" = "no"]
+[then]
+ [echo "bison not found in the search path. Please ensure that it is"]
+ [echo "installed and its directory is included in the search path."]
+ [echo "Then run configure again before attempting to build ABRT."]
+ [exit 1]
+[fi]
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION([0.17])