summaryrefslogtreecommitdiffstats
path: root/src/cli/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2011-05-04 16:16:27 +0200
committerDenys Vlasenko <dvlasenk@redhat.com>2011-05-04 16:16:27 +0200
commitc97efb6b1ca77d3c05e89462a43ff9bad67fedc4 (patch)
treed262481b0348c05450f36b16936d6037adf2517d /src/cli/Makefile.am
parent58e7efce3d5ac71e308e7e44176473cd66e8ad26 (diff)
downloadabrt-c97efb6b1ca77d3c05e89462a43ff9bad67fedc4.tar.gz
abrt-c97efb6b1ca77d3c05e89462a43ff9bad67fedc4.tar.xz
abrt-c97efb6b1ca77d3c05e89462a43ff9bad67fedc4.zip
move abrt-handle-crashdump to abrt-cli package. No code changes
...for assimilation into abrt-cli tool Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'src/cli/Makefile.am')
-rw-r--r--src/cli/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/src/cli/Makefile.am b/src/cli/Makefile.am
index d6cd5ef2..18ff434e 100644
--- a/src/cli/Makefile.am
+++ b/src/cli/Makefile.am
@@ -1,4 +1,6 @@
-bin_PROGRAMS = abrt-cli
+bin_PROGRAMS = \
+ abrt-handle-crashdump \
+ abrt-cli
abrt_cli_SOURCES = \
cli.c \
@@ -19,6 +21,26 @@ abrt_cli_LDADD = \
../lib/libabrt_dbus.la \
$(GLIB_LIBS)
+abrt_handle_crashdump_SOURCES = \
+ abrt-handle-crashdump.c
+abrt_handle_crashdump_CPPFLAGS = \
+ -I$(srcdir)/../include/report -I$(srcdir)/../include \
+ -I$(srcdir)/../lib \
+ -DBIN_DIR=\"$(bindir)\" \
+ -DVAR_RUN=\"$(VAR_RUN)\" \
+ -DCONF_DIR=\"$(CONF_DIR)\" \
+ -DLOCALSTATEDIR='"$(localstatedir)"' \
+ -DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
+ -DDEBUG_INFO_DIR=\"$(DEBUG_INFO_DIR)\" \
+ -DPLUGINS_LIB_DIR=\"$(PLUGINS_LIB_DIR)\" \
+ -DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
+ -DLIBEXEC_DIR=\"$(LIBEXEC_DIR)\" \
+ $(GLIB_CFLAGS) \
+ -D_GNU_SOURCE \
+ -Wall -Wwrite-strings -Werror
+abrt_handle_crashdump_LDADD = \
+ ../lib/libreport.la
+
man_MANS = abrt-cli.1
EXTRA_DIST = $(man_MANS)