summaryrefslogtreecommitdiffstats
path: root/inc/Makefile.am
diff options
context:
space:
mode:
authorJiri Moskovcak <jmoskovc@redhat.com>2010-07-08 16:38:19 +0200
committerJiri Moskovcak <jmoskovc@redhat.com>2010-07-09 11:42:30 +0200
commit6c4ea60aa257907deebcdb346a9d68bbe722837e (patch)
tree9169a621bdb63de41ccc6711636f8e5b6a432c49 /inc/Makefile.am
parent27572201de598e6c097dac708826a724e4154659 (diff)
downloadabrt-6c4ea60aa257907deebcdb346a9d68bbe722837e.tar.gz
abrt-6c4ea60aa257907deebcdb346a9d68bbe722837e.tar.xz
abrt-6c4ea60aa257907deebcdb346a9d68bbe722837e.zip
mv devel header files to inc/ and install them
- header files are required to write the custom plugins plugins without downloading the whole git tree, user just need to install abrt-devel package
Diffstat (limited to 'inc/Makefile.am')
-rw-r--r--inc/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/inc/Makefile.am b/inc/Makefile.am
index 2ccc714f..e668b48a 100644
--- a/inc/Makefile.am
+++ b/inc/Makefile.am
@@ -1 +1,19 @@
-EXTRA_DIST = ABRTException.h CrashTypes.h abrtlib.h abrt_types.h
+HEADER_FILES = \
+ ABRTException.h \
+ abrtlib.h \
+ abrt_types.h \
+ abrt_xmlrpc.h \
+ Action.h \
+ Analyzer.h \
+ CommLayerInner.h \
+ CrashTypes.h \
+ Database.h \
+ DBusCommon.h \
+ DebugDump.h \
+ Observer.h \
+ Plugin.h \
+ Reporter.h \
+ xfuncs.h
+
+lib_includedir=$(includedir)/abrt/
+lib_include_HEADERS = $(HEADER_FILES)