summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2010-12-14 17:17:07 +0100
committerDenys Vlasenko <dvlasenk@redhat.com>2010-12-14 17:17:07 +0100
commitb1f4a3256004e8f12c15511d2b77074a3002b9f2 (patch)
treed87ed73b341bafa0831668ed2a7fdb4431cdcb82 /configure.ac
parent8598b22e101201de4d06ea48f2b500f81f2b30d5 (diff)
downloadabrt-b1f4a3256004e8f12c15511d2b77074a3002b9f2.tar.gz
abrt-b1f4a3256004e8f12c15511d2b77074a3002b9f2.tar.xz
abrt-b1f4a3256004e8f12c15511d2b77074a3002b9f2.zip
jury-rig compile for python2.6; small style fixes
Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 59e5d88a..359e649b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,7 +47,12 @@ PKG_CHECK_MODULES([LIBNOTIFY], [libnotify])
#PKG_CHECK_MODULES([NSS], [nss])
PKG_CHECK_MODULES([XMLRPC], [xmlrpc])
PKG_CHECK_MODULES([XMLRPC_CLIENT], [xmlrpc_client])
-PKG_CHECK_MODULES([PYTHON], [python])
+# Just PKG_CHECK_MODULES([PYTHON], [python]) works only with python2.7+
+# Below, if python is not found, we set up for python2.6 w/o checking:
+PKG_CHECK_MODULES([PYTHON], [python],,[
+ PYTHON_LIBS='-L/usr/lib64 -lpython2.6'
+ PYTHON_CFLAGS='-I/usr/include/python2.6'
+])
PKG_PROG_PKG_CONFIG
AC_ARG_WITH([systemdsystemunitdir],