summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Klic <kklic@redhat.com>2010-08-19 15:32:16 +0200
committerKarel Klic <kklic@redhat.com>2010-08-19 15:32:16 +0200
commit8f4b6e717f6bfec1f35ed2931a76a2793e76bef1 (patch)
treebe83eae81ae8f2114ba2d5aa61b66c294553589a /configure.ac
parent56106ac9e2593e0cc79b964c18354b7b29bc2728 (diff)
downloadabrt-8f4b6e717f6bfec1f35ed2931a76a2793e76bef1.tar.gz
abrt-8f4b6e717f6bfec1f35ed2931a76a2793e76bef1.tar.xz
abrt-8f4b6e717f6bfec1f35ed2931a76a2793e76bef1.zip
Fix an ugly misaligmnent of dirent struct between C and C++ code,
caused by LARGEFILE_SOURCE defined in C++, but not in C.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b78e2df..cd21bab6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,6 +15,8 @@ AC_PROG_CXX
AC_SYS_LARGEFILE
CXXFLAGS="$CXXFLAGS -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \
-D_FILE_OFFSET_BITS=64 -fno-strict-aliasing "
+CFLAGS="$CFLAGS -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \
+ -D_FILE_OFFSET_BITS=64 -fno-strict-aliasing "
AC_CHECK_PROGS(YACC, 'bison -y', [no])
[if test "$YACC" = "no"]