summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJiri Moskovcak <jmoskovc@redhat.com>2010-08-09 13:20:35 +0200
committerJiri Moskovcak <jmoskovc@redhat.com>2010-08-09 13:20:35 +0200
commit194fbbf3d28046b06d699e6c0a5ba725a97b9daf (patch)
tree4155228d0e384ff486e88df9b37676d3f91592d0 /configure.ac
parenta2894aadf126566bd3770b0bff1ab6dee29d8f3e (diff)
downloadabrt-194fbbf3d28046b06d699e6c0a5ba725a97b9daf.tar.gz
abrt-194fbbf3d28046b06d699e6c0a5ba725a97b9daf.tar.xz
abrt-194fbbf3d28046b06d699e6c0a5ba725a97b9daf.zip
added native systemd file rhbz#617316
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5a3addb2..e48ee0d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,13 @@ PKG_CHECK_MODULES([XMLRPC], [xmlrpc])
PKG_CHECK_MODULES([XMLRPC_CLIENT], [xmlrpc_client])
PKG_CHECK_MODULES([POLKIT],[polkit-gobject-1])
+PKG_PROG_PKG_CONFIG
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
+
AC_CHECK_HEADER([libtar.h], [],
[AC_MSG_ERROR([libtar.h is needed to build abrt])])