summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJiri Moskovcak <jmoskovc@redhat.com>2010-03-22 10:40:39 +0100
committerJiri Moskovcak <jmoskovc@redhat.com>2010-03-22 10:40:39 +0100
commit3b57906d9e66519f17a5c5fed2c491fed365ae0a (patch)
tree460f659b898ec25bf00458b8571688d6b82f3764 /Makefile.am
parent8fc120f5704bfb2fb9958b5239ea7a2b9dbfb207 (diff)
downloadabrt-3b57906d9e66519f17a5c5fed2c491fed365ae0a.tar.gz
abrt-3b57906d9e66519f17a5c5fed2c491fed365ae0a.tar.xz
abrt-3b57906d9e66519f17a5c5fed2c491fed365ae0a.zip
added new make targets
- added make test-rpm - added some "magic" into spec file to ease releasing of the git rawhide builds
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ef369e63..61f4e290 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,7 @@ rpm: dist
--define "_builddir `pwd`" \
--define "_srcrpmdir `pwd`" \
-ba abrt.spec
-
+
srpm: dist
rpmbuild --define "_sourcedir `pwd`" \
--define "_rpmdir `pwd`" \
@@ -17,6 +17,24 @@ srpm: dist
--define "_builddir `pwd`" \
--define "_srcrpmdir `pwd`" \
-bs abrt.spec
-
+
+test-rpm: dist
+ rpmbuild --define "_sourcedir `pwd`" \
+ --define "_rpmdir `pwd`" \
+ --define "_specdir `pwd`" \
+ --define "_builddir `pwd`" \
+ --define "_srcrpmdir `pwd`" \
+ --define "_buildid `date +%G%m%e%k%M%S`" \
+ -ba abrt.spec
+
+test-srpm: dist
+ rpmbuild --define "_sourcedir `pwd`" \
+ --define "_rpmdir `pwd`" \
+ --define "_specdir `pwd`" \
+ --define "_builddir `pwd`" \
+ --define "_srcrpmdir `pwd`" \
+ --define "_buildid `date +%G%m%e%k%M%S`" \
+ -bs abrt.spec
+
scratch-build: srpm
koji build --scratch dist-f12 $(PACKAGE)-$(VERSION)-1.fc12.src.rpm