summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am33
1 files changed, 23 insertions, 10 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7a31be45..09d1a0b6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,11 +1,11 @@
-check_PROGRAMS = rt_init rscript
-TESTS = $(check_PROGRAMS) cfg.sh
+TESTRUNS = rt_init rscript parsertest
+check_PROGRAMS = $(TESTRUNS) ourtail
+TESTS = $(TESTRUNS) cfg.sh
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
-#TESTS = $(check_PROGRAMS)
-
+DISTCLEANFILES=rsyslog.pid
test_files = testbench.h runtime-dummy.c
-EXTRA_DIST=1.rstest 2.rstest 3.rstest err1.rstest \
- cfg.sh \
+
+EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
cfg1.cfgtest \
cfg1.testin \
cfg2.cfgtest \
@@ -16,14 +16,27 @@ EXTRA_DIST=1.rstest 2.rstest 3.rstest err1.rstest \
cfg4.testin \
DevNull.cfgtest \
err1.rstest \
- NoExistFile.cfgtest
+ NoExistFile.cfgtest \
+ testruns/parser.conf \
+ testruns/1.parse1 \
+ testruns/rfc3164.parse1 \
+ testruns/rfc5424-1.parse1 \
+ testruns/rfc5424-2.parse1 \
+ testruns/rfc5424-3.parse1 \
+ testruns/rfc5424-4.parse1 \
+ cfg.sh
+
+ourtail_SOURCES = ourtail.c
+
+parsertest_SOURCES = parsertest.c getline.c
+parsertest_LDADD = $(SOL_LIBS)
rt_init_SOURCES = rt-init.c $(test_files)
rt_init_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
-rt_init_LDADD = $(RSRT_LIBS) $(ZLIB_LIBS) $(PTHREADS_LIBS)
+rt_init_LDADD = $(RSRT_LIBS) $(ZLIB_LIBS) $(PTHREADS_LIBS) $(SOL_LIBS)
rt_init_LDFLAGS = -export-dynamic
-rscript_SOURCES = rscript.c $(test_files)
+rscript_SOURCES = rscript.c getline.c $(test_files)
rscript_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
-rscript_LDADD = $(RSRT_LIBS) $(ZLIB_LIBS) $(PTHREADS_LIBS)
+rscript_LDADD = $(RSRT_LIBS) $(ZLIB_LIBS) $(PTHREADS_LIBS) $(SOL_LIBS)
rscript_LDFLAGS = -export-dynamic