summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am32
1 files changed, 29 insertions, 3 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index cd8a19c2..048ef411 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -1,9 +1,36 @@
sbin_PROGRAMS =
man_MANS =
noinst_LTLIBRARIES = librsyslog.la
+pkglib_LTLIBRARIES =
#pkglib_LTLIBRARIES = librsyslog.la
librsyslog_la_SOURCES = \
+ rsyslog.h \
+ atomic.h \
+ syslogd-types.h \
+ module-template.h \
+ obj-types.h \
+ glbl.h \
+ msg.c \
+ msg.h \
+ linkedlist.c \
+ linkedlist.h \
+ objomsr.c \
+ objomsr.h \
+ stringbuf.c \
+ stringbuf.h \
+ datetime.c \
+ datetime.h \
+ srutils.c \
+ srUtils.h \
+ errmsg.c \
+ errmsg.h \
+ debug.c \
+ debug.h \
+ obj.c \
+ obj.h \
+ modules.c \
+ modules.h \
sync.c \
sync.h \
expr.c \
@@ -33,7 +60,7 @@ librsyslog_la_SOURCES = \
queue.c \
queue.h
-librsyslog_la_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags)
+librsyslog_la_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/\" -I$(top_srcdir) $(pthreads_cflags)
#librsyslog_la_LDFLAGS = -module -avoid-version
librsyslog_la_LIBADD =
@@ -41,8 +68,7 @@ librsyslog_la_LIBADD =
# regular expression support
#
if ENABLE_REGEXP
-noinst_LTLIBRARIES += lmregexp.la
-#pkglib_LTLIBRARIES += lmregexp.la
+pkglib_LTLIBRARIES += lmregexp.la
lmregexp_la_SOURCES = regexp.c regexp.h
lmregexp_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
lmregexp_la_LDFLAGS = -module -avoid-version $(rsrt_libs)