summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index bc03c4a7..eeb656d6 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -121,6 +121,13 @@ lmnetstrms_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
lmnetstrms_la_LDFLAGS = -module -avoid-version
lmnetstrms_la_LIBADD =
+# generic stream server framework
+pkglib_LTLIBRARIES += lmstrmsrv.la
+lmstrmsrv_la_SOURCES = strmsrv.c strmsrv.h strms_sess.c strms_sess.h
+lmstrmsrv_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
+lmstrmsrv_la_LDFLAGS = -module -avoid-version
+lmstrmsrv_la_LIBADD =
+
# netstream drivers
# plain tcp driver - main driver