summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 586f03e3..d330ea82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,8 @@ case "${host}" in
*-*-linux*)
;;
*-*-*darwin*|*-*-freebsd*|*-*-netbsd*|*-*-openbsd*)
- AC_DEFINE([OS_BSD], [1], [Description])
+ AC_DEFINE([OS_BSD], [1], [Indicator for a BSD OS])
+ os_bsd = "yes"
;;
esac
@@ -202,7 +203,9 @@ AC_ARG_ENABLE(klog,
esac],
[enable_klog="yes"]
)
-AM_CONDITIONAL(ENABLE_IMKLOGD, test x$enable_klog = xyes)
+AM_CONDITIONAL(ENABLE_IMKLOGD, test x$enable_klog = xyes)
+AM_CONDITIONAL(ENABLE_IMKLOG_BSD, test x$os_bsd = xyes)
+AM_CONDITIONAL(ENABLE_IMKLOG_LINUX, test x$os_bsd = x)
#
# SYSLOG_UNIXAF