summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 20fee5c7..90d684dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,8 +164,10 @@ if test "x$enable_pthreads" != "xno"; then
[pthread_create],
[
AC_DEFINE([USE_PTHREADS], [1], [Multithreading support enabled.])
- pthreads_libs="-lpthread"
- AC_SUBST(pthreads_libs)
+ pthreads_libs="-lpthread"
+ pthreads_cflags="-pthread"
+ AC_SUBST(pthreads_libs)
+ AC_SUBST(pthreads_cflags)
],
[AC_MSG_FAILURE([pthread is missing])],
[-lpthread]