summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 1 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index e755dacb..cc5830b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -740,27 +740,9 @@ AC_ARG_ENABLE(elasticsearch,
[enable_elasticsearch=no]
)
if test "x$enable_elasticsearch" = "xyes"; then
- AC_CHECK_PROG(
- [HAVE_CURL_CONFIG],
- [curl-config],
- [yes],,,
- )
- if test "x${HAVE_CURL_CONFIG}" != "xyes"; then
- AC_MSG_FAILURE([curl-config not found in PATH])
- fi
- AC_CHECK_LIB(
- [curl],
- [curl_global_init],
- [CURL_CFLAGS="`curl-config --cflags`"
- CURL_LIBS="`curl-config --libs`"
- ],
- [AC_MSG_FAILURE([curl library is missing])],
- [`curl-config --libs --cflags`]
- )
+ PKG_CHECK_MODULES([CURL], [libcurl])
fi
AM_CONDITIONAL(ENABLE_ELASTICSEARCH, test x$enable_elasticsearch = xyes)
-AC_SUBST(CURL_CFLAGS)
-AC_SUBST(CURL_LIBS)
# GnuTLS support