summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am49
1 files changed, 46 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 111756f6..76a38322 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,6 +99,26 @@ if ENABLE_OMSTDOUT
SUBDIRS += plugins/omstdout
endif
+if ENABLE_PMLASTMSG
+SUBDIRS += plugins/pmlastmsg
+endif
+
+if ENABLE_PMRFC3164SD
+SUBDIRS += plugins/pmrfc3164sd
+endif
+
+if ENABLE_OMRULESET
+SUBDIRS += plugins/omruleset
+endif
+
+if ENABLE_OMDBALERTING
+SUBDIRS += plugins/omdbalerting
+endif
+
+if ENABLE_OMUDPSPOOF
+SUBDIRS += plugins/omudpspoof
+endif
+
if ENABLE_OMUXSOCK
SUBDIRS += plugins/omuxsock
endif
@@ -135,6 +155,10 @@ if ENABLE_ORACLE
SUBDIRS += plugins/omoracle
endif
+if ENABLE_GUI
+SUBDIRS += java
+endif
+
# tests are added as last element, because tests may need different
# modules that need to be generated first
SUBDIRS += tests
@@ -146,7 +170,26 @@ SUBDIRS += tests
# temporarily be removed below. The intent behind forcing everthing to compile
# in a make distcheck is so that we detect code that accidently was not updated
# when some global update happened.
-DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls --enable-omstdout --enable-omprog --enable-imdiag --enable-shave --enable-extended-tests \
- --enable-omuxsock \
- --enable-imptcp
+DISTCHECK_CONFIGURE_FLAGS= --enable-gssapi_krb5 \
+ --enable-imfile \
+ --enable-snmp \
+ --enable-pgsql \
+ --enable-libdbi \
+ --enable-mysql \
+ --enable-relp \
+ --enable-rsyslogd \
+ --enable-mail \
+ --enable-klog \
+ --enable-diagtools \
+ --enable-gnutls \
+ --enable-omstdout \
+ --enable-pmlastmsg \
+ --enable-omruleset \
+ --enable-omprog \
+ --enable-imdiag \
+ --enable-imptcp \
+ --enable-omuxsock \
+ --enable-shave \
+ --enable-extended-tests \
+ --enable-memcheck
ACLOCAL_AMFLAGS = -I m4