summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 29 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 62fc1357..41b2de73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,6 +59,10 @@ if ENABLE_IMKLOG
SUBDIRS += plugins/imklog
endif
+if ENABLE_IMSOLARIS
+SUBDIRS += plugins/imsolaris
+endif
+
if ENABLE_GSSAPI
SUBDIRS += plugins/omgssapi plugins/imgssapi
endif
@@ -99,6 +103,10 @@ if ENABLE_OMRULESET
SUBDIRS += plugins/omruleset
endif
+if ENABLE_OMDBALERTING
+SUBDIRS += plugins/omdbalerting
+endif
+
if ENABLE_OMUDPSPOOF
SUBDIRS += plugins/omudpspoof
endif
@@ -146,5 +154,25 @@ SUBDIRS += tests
# temporarily be removed below. The intent behind forcing everthing to compile
# in a make distcheck is so that we detect code that accidently was not updated
# when some global update happened.
-DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls --enable-omstdout --enable-omruleset --enable-omprog --enable-imdiag --enable-shave --enable-memcheck --enable-extended-tests
+DISTCHECK_CONFIGURE_FLAGS= --enable-gssapi_krb5 \
+ --enable-imfile \
+ --enable-snmp \
+ --enable-pgsql \
+ --enable-libdbi \
+ --enable-mysql \
+ --enable-omtemplate \
+ --enable-imtemplate \
+ --enable-relp \
+ --enable-rsyslogd \
+ --enable-mail \
+ --enable-klog \
+ --enable-diagtools \
+ --enable-gnutls \
+ --enable-omstdout \
+ --enable-omruleset \
+ --enable-omprog \
+ --enable-imdiag \
+ --enable-shave \
+ --enable-extended-tests \
+ --enable-memcheck
ACLOCAL_AMFLAGS = -I m4