summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am164
1 files changed, 85 insertions, 79 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c1b24bd..e78a413c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,97 +1,103 @@
-sbin_PROGRAMS = rklogd rfc3195d rsyslogd
-
-rklogd_SOURCES = \
- klogd.c \
- klogd.h \
- syslog.c \
- pidfile.c \
- pidfile.h \
- ksym.c \
- ksyms.h \
- ksym_mod.c \
- module.h
-
-rfc3195d_SOURCES = rfc3195d.c rsyslog.h
-
-rsyslogd_SOURCES = \
- syslogd.c \
- syslogd.h \
- pidfile.c \
- pidfile.h \
- template.c \
- outchannel.c \
- stringbuf.c \
- stringbuf.h \
- srUtils.c \
- srUtils.h \
- parse.c \
- parse.h \
- syslogd-types.h \
- template.h \
- outchannel.h \
- liblogging-stub.h \
- sync.c \
- sync.h \
- net.c \
- net.h \
- msg.c \
- msg.h \
- expr.c \
- omshell.c \
- omshell.h \
- omusrmsg.c \
- omusrmsg.h \
- omfwd.c \
- omfwd.h \
- tcpsyslog.c \
- tcpsyslog.h \
- omfile.c \
- omfile.h \
- omdiscard.c \
- omdiscard.h \
- modules.c \
- modules.h \
- module-template.h \
- objomsr.c \
- objomsr.h \
- cfsysline.c \
- cfsysline.h \
- linkedlist.c \
- linkedlist.h \
- iminternal.c \
- iminternal.h \
- action.c \
- action.h \
- gss-misc.c \
- gss-misc.h
-
-rsyslogd_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/\" $(pthreads_cflags)
-rsyslogd_LDADD = $(zlib_libs) $(pthreads_libs) $(gss_libs) $(dl_libs) $(rt_libs)
-rsyslogd_LDFLAGS = -export-dynamic
-
-man_MANS = rfc3195d.8 rklogd.8 rsyslogd.8 rsyslog.conf.5
+sbin_PROGRAMS =
+pkglib_LTLIBRARIES =
+
+
+if ENABLE_INET
+pkglib_LTLIBRARIES += lmtcpsrv.la lmtcpclt.la
+#
+#
+# TCP (stream) server support
+#
+lmtcpsrv_la_SOURCES = \
+ tcps_sess.c \
+ tcps_sess.h \
+ tcpsrv.c \
+ tcpsrv.h
+lmtcpsrv_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
+lmtcpsrv_la_LDFLAGS = -module -avoid-version
+lmtcpsrv_la_LIBADD =
+
+#
+# TCP (stream) client support
+#
+lmtcpclt_la_SOURCES = \
+ tcpclt.c \
+ tcpclt.h
+lmtcpclt_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
+lmtcpclt_la_LDFLAGS = -module -avoid-version
+lmtcpclt_la_LIBADD =
+
+endif # if ENABLE_INET
+
+#
+# gssapi support
+#
+if ENABLE_GSSAPI
+pkglib_LTLIBRARIES += lmgssutil.la
+lmgssutil_la_SOURCES = gss-misc.c gss-misc.h
+lmgssutil_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
+lmgssutil_la_LDFLAGS = -module -avoid-version
+lmgssutil_la_LIBADD = $(gss_libs)
+endif
EXTRA_DIST = \
- redhat/rsyslog.conf \
- redhat/rsyslog.init \
- redhat/rsyslog.log \
- redhat/rsyslog.sysconfig \
freebsd/rsyslogd \
slackware/rc.rsyslogd \
contrib/README \
- $(man_MANS)
+ rsyslog.conf \
+ COPYING.LESSER \
+ contrib/gnutls/ca.pem \
+ contrib/gnutls/cert.pem \
+ contrib/gnutls/key.pem
-SUBDIRS = doc
+SUBDIRS = doc runtime . tests
+SUBDIRS += plugins/immark plugins/imuxsock plugins/imtcp plugins/imudp plugins/omtesting
+
+if ENABLE_RSYSLOGD
+SUBDIRS += tools
+endif
+
+if ENABLE_IMKLOG
+SUBDIRS += plugins/imklog
+endif
if ENABLE_GSSAPI
-SUBDIRS += plugins/omgssapi
+SUBDIRS += plugins/omgssapi plugins/imgssapi
+endif
+
+if ENABLE_RELP
+SUBDIRS += plugins/omrelp plugins/imrelp
endif
if ENABLE_MYSQL
SUBDIRS += plugins/ommysql
endif
+if ENABLE_OMLIBDBI
+SUBDIRS += plugins/omlibdbi
+endif
+
if ENABLE_PGSQL
SUBDIRS += plugins/ompgsql
endif
+
+if ENABLE_SNMP
+SUBDIRS += plugins/omsnmp
+endif
+
+if ENABLE_IMTEMPLATE
+SUBDIRS += plugins/imtemplate
+endif
+
+if ENABLE_IMFILE
+SUBDIRS += plugins/imfile
+endif
+
+if ENABLE_MAIL
+SUBDIRS += plugins/ommail
+endif
+
+if ENABLE_RFC3195
+SUBDIRS += plugins/im3195
+endif