summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 67b3e962..c4fc4b68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,8 +50,6 @@ rsyslogd_SOURCES = \
queue.h \
sync.c \
sync.h \
- net.c \
- net.h \
obj.c \
obj.h \
obj-types.h \
@@ -111,6 +109,17 @@ tcpsrv_la_LDFLAGS = -module -avoid-version
tcpsrv_la_LIBADD =
#
+# network support
+#
+if ENABLE_INET
+pkglib_LTLIBRARIES += net.la
+net_la_SOURCES = net.c net.h
+net_la_CPPFLAGS = $(pthreads_cflags)
+net_la_LDFLAGS = -module -avoid-version
+net_la_LIBADD =
+endif
+
+#
# gssapi support
#
if ENABLE_GSSAPI