summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-06-03 14:45:09 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-06-03 14:45:09 +0200
commitf54e72cec06f21f4af939c70541e8a339b7e56ff (patch)
tree12912644e7d614082ea21715367996e43df3a55d /tools/Makefile.am
parent4f742a8e32c43dc9b514ceaf80f4d17e697dfdf6 (diff)
downloadrsyslog-f54e72cec06f21f4af939c70541e8a339b7e56ff.tar.gz
rsyslog-f54e72cec06f21f4af939c70541e8a339b7e56ff.tar.xz
rsyslog-f54e72cec06f21f4af939c70541e8a339b7e56ff.zip
first proof of concept on zipped file writer
This DOES NOT work sufficiently well, I just wanted to verify that zip writing is possible and files are readable. Will be refined soon.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index e523b854..f0f9afab 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -26,8 +26,10 @@ rsyslogd_LDADD = $(ZLIB_LIBS) $(PTHREADS_LIBS) $(RSRT_LIBS) $(SOL_LIBS)
rsyslogd_LDFLAGS = -export-dynamic
if ENABLE_DIAGTOOLS
-sbin_PROGRAMS += rsyslog_diag_hostname msggen
+sbin_PROGRAMS += rsyslog_diag_hostname msggen zpipe
rsyslog_diag_hostname_SOURCES = gethostn.c
+zpipe_SOURCES = zpipe.c
+zpipe_LDADD = -lz
msggen_SOURCES = msggen.c
endif