summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2011-03-11 12:47:54 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2011-03-11 12:47:54 +0100
commitc509177c17288655f308ef68fb2cf7b005a83aed (patch)
tree00767733eac4341874da23bf881c22887ca11b4c /tests/Makefile.am
parenta2cbbc1a87b36a335e570005fb4df38cb8d508ad (diff)
parent6dbd70732a19a13bacae7b4bea07097458974cc9 (diff)
downloadrsyslog-c509177c17288655f308ef68fb2cf7b005a83aed.tar.gz
rsyslog-c509177c17288655f308ef68fb2cf7b005a83aed.tar.xz
rsyslog-c509177c17288655f308ef68fb2cf7b005a83aed.zip
Merge branch 'v5-beta'
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8a42cc59..e3fb406d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
if ENABLE_TESTBENCH
TESTRUNS = rt_init rscript
-check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq msleep randomgen diagtalker uxsockrcvr syslog_caller syslog_inject
+check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq msleep randomgen diagtalker uxsockrcvr syslog_caller syslog_inject inputfilegen
TESTS = $(TESTRUNS) cfg.sh
if ENABLE_IMDIAG
@@ -131,6 +131,13 @@ if ENABLE_EXTENDED_TESTS
TESTS += random.sh
endif
+if ENABLE_IMFILE
+TESTS += imfile-basic.sh
+if HAVE_VALGRIND
+TESTS += imfile-basic-vg.sh
+endif
+endif
+
endif # if ENABLE_TESTBENCH
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
@@ -336,6 +343,9 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/complex1.conf \
random.sh \
testsuites/random.conf \
+ imfile-basic.sh \
+ imfile-basic-vg.sh \
+ testsuites/imfile-basic.conf \
dynfile_invld_async.sh \
dynfile_invld_sync.sh \
dynfile_cachemiss.sh \
@@ -426,6 +436,9 @@ diagtalker_LDADD = $(SOL_LIBS)
randomgen_SOURCES = randomgen.c
randomgen_LDADD = $(SOL_LIBS)
+inputfilegen_SOURCES = inputfilegen.c
+inputfilegen_LDADD = $(SOL_LIBS)
+
nettester_SOURCES = nettester.c getline.c
nettester_LDADD = $(SOL_LIBS)