summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-05-19 09:24:03 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-05-19 09:24:03 +0200
commitcb0fa751b7e18ffe71aec84bccfeaf04fca7ff13 (patch)
treeb985c583bca6486cdf628a56a24c13c37288f2c8 /tests/Makefile.am
parentfe5bea77ac2533faab3b7b73bc253c4dc7d702bc (diff)
parent55714cdb440b4baa32f88d55316755555ef93607 (diff)
downloadrsyslog-cb0fa751b7e18ffe71aec84bccfeaf04fca7ff13.tar.gz
rsyslog-cb0fa751b7e18ffe71aec84bccfeaf04fca7ff13.tar.xz
rsyslog-cb0fa751b7e18ffe71aec84bccfeaf04fca7ff13.zip
Merge branch 'master' into tmp
Conflicts: tests/Makefile.am
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 087fa6af..88f6a200 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,9 @@
TESTRUNS = rt_init rscript
check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
-TESTS = $(TESTRUNS) cfg.sh fieldtest.sh parsertest.sh omod-if-array.sh da-mainmsg-q.sh diskqueue.sh manytcp.sh
+TESTS = $(TESTRUNS) cfg.sh fieldtest.sh da-mainmsg-q.sh diskqueue.sh manytcp.sh
+if ENABLE_OMSTDOUT
+TESTS += omod-if-array.sh parsertest.sh
+endif
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
DISTCLEANFILES=rsyslog.pid
test_files = testbench.h runtime-dummy.c
@@ -8,7 +11,7 @@ test_files = testbench.h runtime-dummy.c
EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
cfg1.cfgtest \
cfg1.testin \
- cfg2.cfgtest \
+ cfg2.cfgtest \
cfg2.testin \
cfg3.cfgtest \
cfg3.testin \