summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2011-03-11 11:16:41 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2011-03-11 11:16:41 +0100
commit9a53ec419e9d9e25a81b26a01ce5b035631e321a (patch)
tree5e32a26ee0ef04c9683221dae1146f10e43d0c33 /tests/Makefile.am
parentdffb2bab8cb52599626b82587da09df39b16e7aa (diff)
parent4195f9cb08cddaeae37dc88c5e879d84391b4359 (diff)
downloadrsyslog-9a53ec419e9d9e25a81b26a01ce5b035631e321a.tar.gz
rsyslog-9a53ec419e9d9e25a81b26a01ce5b035631e321a.tar.xz
rsyslog-9a53ec419e9d9e25a81b26a01ce5b035631e321a.zip
Merge branch 'v4-stable' into v5-stable
Conflicts: tests/Makefile.am tests/diag.sh tests/tcpflood.c
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3f703fcb..03a4985a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
if ENABLE_TESTBENCH
TESTRUNS = rt_init rscript
-check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq msleep randomgen diagtalker uxsockrcvr
+check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq msleep randomgen diagtalker uxsockrcvr inputfilegen
TESTS = $(TESTRUNS) cfg.sh \
arrayqueue.sh \
linkedlistqueue.sh \
@@ -85,6 +85,10 @@ if ENABLE_EXTENDED_TESTS
TESTS += random.sh
endif
+if ENABLE_IMFILE
+TESTS += imfile-basic.sh
+endif
+
endif # if ENABLE_TESTBENCH
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
@@ -278,6 +282,8 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/complex1.conf \
random.sh \
testsuites/random.conf \
+ imfile-basic.sh \
+ testsuites/imfile-basic.conf \
dynfile_invld_async.sh \
dynfile_invld_sync.sh \
dynfile_cachemiss.sh \
@@ -337,6 +343,9 @@ diagtalker_LDADD = $(SOL_LIBS)
randomgen_SOURCES = randomgen.c
randomgen_LDADD = $(SOL_LIBS)
+inputfilegen_SOURCES = inputfilegen.c
+inputfilegen_LDADD = $(SOL_LIBS)
+
nettester_SOURCES = nettester.c getline.c
nettester_LDADD = $(SOL_LIBS)