summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-04-09 12:27:59 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-04-09 12:27:59 +0200
commit87a957b0f5686ec3a50c98f3d1cf3019b636e700 (patch)
tree00af9694aa29b1e97f6d9b1efff5e78323316412 /tests/Makefile.am
parentf139dc28feb74f9c8b66736905ae7d3cacd035b6 (diff)
parent5ef852f4a3f030f61254a963b0d2dca290933e3c (diff)
downloadrsyslog-87a957b0f5686ec3a50c98f3d1cf3019b636e700.tar.gz
rsyslog-87a957b0f5686ec3a50c98f3d1cf3019b636e700.tar.xz
rsyslog-87a957b0f5686ec3a50c98f3d1cf3019b636e700.zip
Merge branch 'v4-stable-solaris' into beta
Conflicts: runtime/Makefile.am runtime/rsyslog.c tests/nettester.c tools/syslogd.c
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 747b10cf..e2e3d69b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
if ENABLE_TESTBENCH
TESTRUNS = rt_init rscript
-check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
+check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq msleep randomgen
TESTS = $(TESTRUNS) cfg.sh \
arrayqueue.sh \
linkedlistqueue.sh \
@@ -32,6 +32,7 @@ TESTS = $(TESTRUNS) cfg.sh \
dynfile_invld_sync.sh \
dynfile_invalid2.sh \
complex1.sh \
+ random.sh \
queue-persist.sh \
pipeaction.sh \
execonlyonce.sh \
@@ -229,6 +230,8 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/gzipwr_large_dynfile.conf \
complex1.sh \
testsuites/complex1.conf \
+ random.sh \
+ testsuites/random.conf \
dynfile_invld_async.sh \
dynfile_invld_sync.sh \
dynfile_cachemiss.sh \
@@ -256,11 +259,15 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
cfg.sh
ourtail_SOURCES = ourtail.c
+msleep_SOURCES = msleep.c
chkseq_SOURCES = chkseq.c
tcpflood_SOURCES = tcpflood.c
tcpflood_LDADD = $(SOL_LIBS)
+randomgen_SOURCES = randomgen.c
+randomgen_LDADD = $(SOL_LIBS)
+
nettester_SOURCES = nettester.c getline.c
nettester_LDADD = $(SOL_LIBS)