summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-03-17 16:39:18 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2010-03-17 16:39:18 +0100
commit679434312c20d9651faff26b8b3a5ab203be7ff3 (patch)
tree105bf490b92b0033e3f8c2a5e070136d40337741 /tests/Makefile.am
parentba0f23182a55b26b2265d2138c707cbc7ddbb72e (diff)
downloadrsyslog-679434312c20d9651faff26b8b3a5ab203be7ff3.tar.gz
rsyslog-679434312c20d9651faff26b8b3a5ab203be7ff3.tar.xz
rsyslog-679434312c20d9651faff26b8b3a5ab203be7ff3.zip
added test to check for deadlock condition in async-written files
Note that this introduces a test case that breaks the current code. This commit does NOT yet provide the necessary code patch. Thus make check does currently hang.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index bc7902b1..3c2223d9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,6 +14,7 @@ TESTS = $(TESTRUNS) cfg.sh \
asynwr_small.sh \
asynwr_tinybuf.sh \
asynwr_large.sh \
+ asynwr_deadlock.sh \
gzipwr_large.sh \
gzipwr_large_dynfile.sh \
complex1.sh \
@@ -154,6 +155,8 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/asynwr_tinybuf.conf \
asynwr_large.sh \
testsuites/asynwr_large.conf \
+ asynwr_deadlock.sh \
+ testsuites/asynwr_deadlock.conf \
gzipwr_large.sh \
testsuites/gzipwr_large.conf \
gzipwr_large_dynfile.sh \