summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-03-25 09:35:49 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2010-03-25 09:35:49 +0100
commit5deea302b0c594b267e0450bdbb82954d2459a61 (patch)
treed79b3e8843fef0e653b5d4d891369ceaef3b54c5 /tests/Makefile.am
parent2f8b5cafd0dcc5f09b7b64f5015a2aebd1c7b31c (diff)
downloadrsyslog-5deea302b0c594b267e0450bdbb82954d2459a61.tar.gz
rsyslog-5deea302b0c594b267e0450bdbb82954d2459a61.tar.xz
rsyslog-5deea302b0c594b267e0450bdbb82954d2459a61.zip
replaced sleep in test suite by a small self-crafted tool
subsecond sleep did not work on all platforms
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9e04ea1e..2a4213f8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
if ENABLE_TESTBENCH
TESTRUNS = rt_init rscript
-check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
+check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq msleep
TESTS = $(TESTRUNS) cfg.sh \
validation-run.sh \
imtcp-multiport.sh \
@@ -193,6 +193,7 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
cfg.sh
ourtail_SOURCES = ourtail.c
+msleep_SOURCES = msleep.c
chkseq_SOURCES = chkseq.c
tcpflood_SOURCES = tcpflood.c