summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-04-22 18:37:56 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-04-22 18:37:56 +0200
commit50174408b02cd0e5553c5e92a73cc43fb1364db9 (patch)
tree95778349232645901107fef5fc8825aa6e1fa21a /tests/Makefile.am
parente4b3f6d287d74b34d27b4e296c33cb3f1294a58c (diff)
downloadrsyslog-50174408b02cd0e5553c5e92a73cc43fb1364db9.tar.gz
rsyslog-50174408b02cd0e5553c5e92a73cc43fb1364db9.tar.xz
rsyslog-50174408b02cd0e5553c5e92a73cc43fb1364db9.zip
added test for DA queue mode (in main msg queue) - needs more work
The problem is that the rsyslog engine writes messages too quickly, so that the queue never enters DA mode. We still have some look contemption. One possible solution (hopefully) is to finally move the parser code out of imtcp and onto the next thread. Need to address these issues first, then come back to the test case.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0f4cbce1..b4509dee 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
TESTRUNS = rt_init rscript
check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
-TESTS = $(TESTRUNS) cfg.sh parsertest.sh omod-if-array.sh manytcp.sh diskqueue.sh
+TESTS = $(TESTRUNS) cfg.sh parsertest.sh omod-if-array.sh da-mainmsg-q.sh diskqueue.sh manytcp.sh
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
DISTCLEANFILES=rsyslog.pid
test_files = testbench.h runtime-dummy.c
@@ -29,6 +29,8 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
parsertest.sh \
diskqueue.sh \
testsuites/diskqueue.conf \
+ da-mainmsg-q.sh \
+ testsuites/da-mainmsg-q.conf \
manytcp.sh \
testsuites/manytcp.conf \
omod-if-array.sh \