summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-05-20 16:08:23 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-05-20 16:08:23 +0200
commit8088f9b01a8344c63e7874836721c79d94a01d25 (patch)
treefb97cee60b0f04fcd8e6bbcdd4c680cb75137747 /tests/Makefile.am
parent9f45b80ea9ea86d516c895d97fd8670df37e319e (diff)
downloadrsyslog-8088f9b01a8344c63e7874836721c79d94a01d25.tar.gz
rsyslog-8088f9b01a8344c63e7874836721c79d94a01d25.tar.xz
rsyslog-8088f9b01a8344c63e7874836721c79d94a01d25.zip
added explicit (base) test for linkedList and FixedArray queue modes
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 88f6a200..a7736312 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,7 @@
TESTRUNS = rt_init rscript
check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
-TESTS = $(TESTRUNS) cfg.sh fieldtest.sh da-mainmsg-q.sh diskqueue.sh manytcp.sh
+TESTS = $(TESTRUNS) cfg.sh fieldtest.sh arrayqueue.sh linkedlistqueue.sh da-mainmsg-q.sh \
+ diskqueue.sh manytcp.sh
if ENABLE_OMSTDOUT
TESTS += omod-if-array.sh parsertest.sh
endif
@@ -42,6 +43,10 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
fieldtest.sh \
diskqueue.sh \
testsuites/diskqueue.conf \
+ arrayqueue.sh \
+ testsuites/arrayqueue.conf \
+ linkedlistqueue.sh \
+ testsuites/linkedlistqueue.conf \
da-mainmsg-q.sh \
testsuites/da-mainmsg-q.conf \
manytcp.sh \