summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-05-28 19:01:34 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-05-28 19:01:34 +0200
commit29cacc3c8ad6694b1ae2a5480fca7059773d06f0 (patch)
tree1c4996d03a90ddb4ad6ea236ee8f72194a13b99e /tests/Makefile.am
parentcbbf1586a204a897a050b6cb294b120e3ff5f23c (diff)
parentd7c98e7a6ec28a6c76bccf16d83f36b34a705410 (diff)
downloadrsyslog-29cacc3c8ad6694b1ae2a5480fca7059773d06f0.tar.gz
rsyslog-29cacc3c8ad6694b1ae2a5480fca7059773d06f0.tar.xz
rsyslog-29cacc3c8ad6694b1ae2a5480fca7059773d06f0.zip
Merge branch 'master' into v5-devel
Conflicts: tests/Makefile.am
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a0723c9d..dfcbb598 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,8 @@
TESTRUNS = rt_init rscript
check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
TESTS = $(TESTRUNS) cfg.sh arrayqueue.sh linkedlistqueue.sh da-mainmsg-q.sh \
+ validation-run.sh \
+ imtcp-multiport.sh \
diskqueue.sh manytcp.sh \
queue-persist.sh \
daqueue-persist.sh
@@ -8,6 +10,7 @@ TESTS = $(TESTRUNS) cfg.sh arrayqueue.sh linkedlistqueue.sh da-mainmsg-q.sh \
if ENABLE_OMSTDOUT
TESTS += omod-if-array.sh parsertest.sh inputname.sh fieldtest.sh
endif
+
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
DISTCLEANFILES=rsyslog.pid '$(abs_top_builddir)'/DiagTalker.class
test_files = testbench.h runtime-dummy.c
@@ -15,6 +18,10 @@ test_files = testbench.h runtime-dummy.c
check_JAVA = DiagTalker.java
EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
+ validation-run.sh \
+ testsuites/invalid.conf \
+ testsuites/valid.conf \
+ cfg.sh \
cfg1.cfgtest \
cfg1.testin \
cfg2.cfgtest \