summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-03-31 19:00:16 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-31 19:00:16 +0200
commitec9e031599016b9eb6f9ac3fd8298ee4fcb0364f (patch)
tree2be91c17473f4d6185c7cd7b818effa61de7211e /tests/Makefile.am
parent8e29c1fc47523c894b78894d6fdeb43f2d97811d (diff)
downloadrsyslog-ec9e031599016b9eb6f9ac3fd8298ee4fcb0364f.tar.gz
rsyslog-ec9e031599016b9eb6f9ac3fd8298ee4fcb0364f.tar.xz
rsyslog-ec9e031599016b9eb6f9ac3fd8298ee4fcb0364f.zip
changed parser test suite to be c-program based
I finally removed the tcl script because tcl costs a lot of time if you do not invest the full learning cycle, plus I have not everything avaible I need on Solaris. With C, I am quicker and I also can create a superior solution. So I finally switched. Took much less time than the initial tcl script...
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f22ca139..f941f3a6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,12 +1,10 @@
-check_PROGRAMS = rt_init rscript
-TESTS = $(check_PROGRAMS) cfg.sh parsertest
+check_PROGRAMS = rt_init rscript parsertest
+TESTS = $(check_PROGRAMS) cfg.sh
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
DISTCLEANFILES=rsyslog.pid
test_files = testbench.h runtime-dummy.c
-EXTRA_DIST=parser.tcl \
- 1.rstest 2.rstest 3.rstest err1.rstest \
- cfg.sh \
+EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
cfg1.cfgtest \
cfg1.testin \
cfg2.cfgtest \
@@ -25,7 +23,7 @@ EXTRA_DIST=parser.tcl \
testruns/rfc5424-2.parse1 \
testruns/rfc5424-3.parse1 \
testruns/rfc5424-4.parse1 \
- parsertest
+ cfg.sh
rt_init_SOURCES = rt-init.c $(test_files)
rt_init_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)