summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-05-28 18:34:17 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-05-28 18:34:17 +0200
commitd7c98e7a6ec28a6c76bccf16d83f36b34a705410 (patch)
tree66807ada649997bb6e5c8928a6a95870f43d926e /tests/Makefile.am
parentc6a2dafb2fc5d186ef146035f270a4819075eab1 (diff)
parent8d8befaeca0d9ed3f096780e499a3231f16585c4 (diff)
downloadrsyslog-d7c98e7a6ec28a6c76bccf16d83f36b34a705410.tar.gz
rsyslog-d7c98e7a6ec28a6c76bccf16d83f36b34a705410.tar.xz
rsyslog-d7c98e7a6ec28a6c76bccf16d83f36b34a705410.zip
Merge branch 'beta' into master
Conflicts: tests/Makefile.am
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7a7b8147..e93aba10 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,9 +1,11 @@
TESTRUNS = rt_init rscript
check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
-TESTS = $(TESTRUNS) cfg.sh manytcp.sh diskqueue.sh imtcp-multiport.sh queue-persist.sh
+TESTS = $(TESTRUNS) cfg.sh manytcp.sh diskqueue.sh imtcp-multiport.sh queue-persist.sh \
+ validation-run.sh
if ENABLE_OMSTDOUT
TESTS += omod-if-array.sh parsertest.sh inputname.sh fieldtest.sh
endif
+
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
DISTCLEANFILES=rsyslog.pid '$(abs_top_builddir)'/DiagTalker.class
test_files = testbench.h runtime-dummy.c
@@ -11,6 +13,10 @@ test_files = testbench.h runtime-dummy.c
check_JAVA = DiagTalker.java
EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
+ validation-run.sh \
+ testsuites/invalid.conf \
+ testsuites/valid.conf \
+ cfg.sh \
cfg1.cfgtest \
cfg1.testin \
cfg2.cfgtest \