summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-04-03 17:54:09 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-04-03 17:54:09 +0200
commitce6b7e86cdd63ba1540d20aa22403d2b13d2e59f (patch)
tree3d712651f8ffcc2b5e67709e0e4916de8cd77668 /tests/Makefile.am
parent9103817f9fe811b49938036a1f9ff23672a9ec44 (diff)
downloadrsyslog-ce6b7e86cdd63ba1540d20aa22403d2b13d2e59f.tar.gz
rsyslog-ce6b7e86cdd63ba1540d20aa22403d2b13d2e59f.tar.xz
rsyslog-ce6b7e86cdd63ba1540d20aa22403d2b13d2e59f.zip
improved test suite and added test for new output module interface
The testbench has now a generic driver that can run a whole class of test suites just by providing a config file and test cases. This does not cover all testing needs, but a lot. We have now added one test for the new array-passing output plugin interface.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am28
1 files changed, 16 insertions, 12 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 09d1a0b6..ab1c5a62 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
-TESTRUNS = rt_init rscript parsertest
-check_PROGRAMS = $(TESTRUNS) ourtail
-TESTS = $(TESTRUNS) cfg.sh
+TESTRUNS = rt_init rscript
+check_PROGRAMS = $(TESTRUNS) ourtail udptester
+TESTS = $(TESTRUNS) cfg.sh parsertest.sh omod-if-array.sh
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
DISTCLEANFILES=rsyslog.pid
test_files = testbench.h runtime-dummy.c
@@ -17,19 +17,23 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
DevNull.cfgtest \
err1.rstest \
NoExistFile.cfgtest \
- testruns/parser.conf \
- testruns/1.parse1 \
- testruns/rfc3164.parse1 \
- testruns/rfc5424-1.parse1 \
- testruns/rfc5424-2.parse1 \
- testruns/rfc5424-3.parse1 \
- testruns/rfc5424-4.parse1 \
+ testsuites/parse1.conf \
+ testsuites/1.parse1 \
+ testsuites/rfc3164.parse1 \
+ testsuites/rfc5424-1.parse1 \
+ testsuites/rfc5424-2.parse1 \
+ testsuites/rfc5424-3.parse1 \
+ testsuites/rfc5424-4.parse1 \
+ testsuites/omod-if-array.conf \
+ testsuites/1.omod-if-array \
+ parsertest.sh \
+ omod-if-array.sh \
cfg.sh
ourtail_SOURCES = ourtail.c
-parsertest_SOURCES = parsertest.c getline.c
-parsertest_LDADD = $(SOL_LIBS)
+udptester_SOURCES = udptester.c getline.c
+udptester_LDADD = $(SOL_LIBS)
rt_init_SOURCES = rt-init.c $(test_files)
rt_init_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)