summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-04-08 17:48:02 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-04-08 17:48:02 +0200
commit7cc7166cb24e50e48cab1cbb3c19c8c17d95ace7 (patch)
treedf78b696c13f5b4fc15f061c1ed03112d631a470 /tests/Makefile.am
parent51e690f720b4a53a431e7a536b2fe8c25e866f7d (diff)
downloadrsyslog-7cc7166cb24e50e48cab1cbb3c19c8c17d95ace7.tar.gz
rsyslog-7cc7166cb24e50e48cab1cbb3c19c8c17d95ace7.tar.xz
rsyslog-7cc7166cb24e50e48cab1cbb3c19c8c17d95ace7.zip
added new test case for many tcp connections
It is checked that many tcp connections are properly handled. While adding this test, I noticed that there is a bug in imtcp that prevents creation of more than 200 connections. This bug still exists, so the test suite currently fails (what is correct). Will be addressed soon.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index fa662a3e..53a81a93 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
TESTRUNS = rt_init rscript
-check_PROGRAMS = $(TESTRUNS) ourtail nettester
-TESTS = $(TESTRUNS) cfg.sh parsertest.sh omod-if-array.sh
+check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
+TESTS = $(TESTRUNS) cfg.sh parsertest.sh omod-if-array.sh manytcp.sh
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
DISTCLEANFILES=rsyslog.pid
test_files = testbench.h runtime-dummy.c
@@ -27,10 +27,13 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/omod-if-array.conf \
testsuites/1.omod-if-array \
parsertest.sh \
+ manytcp.sh \
omod-if-array.sh \
cfg.sh
ourtail_SOURCES = ourtail.c
+tcpflood_SOURCES = tcpflood.c
+chkseq_SOURCES = chkseq.c
nettester_SOURCES = nettester.c getline.c
nettester_LDADD = $(SOL_LIBS)