summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-06-19 11:30:57 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-06-19 11:30:57 +0200
commit77c992e2155420702460e835ce2d561cf2d10fcb (patch)
treef8349fbffac3264b8233c55499f285d690637e57 /tests/Makefile.am
parentdc603a3dbf0bc0654830e7830a07816c23c85ce5 (diff)
downloadrsyslog-77c992e2155420702460e835ce2d561cf2d10fcb.tar.gz
rsyslog-77c992e2155420702460e835ce2d561cf2d10fcb.tar.xz
rsyslog-77c992e2155420702460e835ce2d561cf2d10fcb.zip
fully optimized datetime module and enhanced test suite
tests for the various timestamp formats have been added
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0800f667..955ad405 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,7 +10,11 @@ TESTS = $(TESTRUNS) cfg.sh \
queue-persist.sh
if ENABLE_OMSTDOUT
-TESTS += omod-if-array.sh parsertest.sh inputname.sh fieldtest.sh
+TESTS += omod-if-array.sh \
+ parsertest.sh \
+ timestamp.sh \
+ inputname.sh \
+ fieldtest.sh
endif
endif # if ENABLE_TESTBENCH
@@ -37,6 +41,22 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
DevNull.cfgtest \
err1.rstest \
NoExistFile.cfgtest \
+ timestamp.sh \
+ testsuites/ts3164.conf \
+ testsuites/mon1digit.ts3164 \
+ testsuites/mon2digit.ts3164 \
+ testsuites/Jan.ts3164 \
+ testsuites/Feb.ts3164 \
+ testsuites/Mar.ts3164 \
+ testsuites/Apr.ts3164 \
+ testsuites/May.ts3164 \
+ testsuites/Jun.ts3164 \
+ testsuites/Jul.ts3164 \
+ testsuites/Aug.ts3164 \
+ testsuites/Sep.ts3164 \
+ testsuites/Oct.ts3164 \
+ testsuites/Nov.ts3164 \
+ testsuites/Dec.ts3164 \
testsuites/parse1.conf \
testsuites/field1.conf \
testsuites/1.parse1 \