summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-06-13 17:21:03 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-06-13 17:21:03 +0200
commit4f32b629906f078ea81637829dde136a27b214e5 (patch)
treec6a4c2830c99575edf7b272a4517d89094bb66b0 /tests/Makefile.am
parentfa3451aaa466ba7da28de6b324b4f90bab3ad4ef (diff)
downloadrsyslog-4f32b629906f078ea81637829dde136a27b214e5.tar.gz
rsyslog-4f32b629906f078ea81637829dde136a27b214e5.tar.xz
rsyslog-4f32b629906f078ea81637829dde136a27b214e5.zip
begun building a testbench
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 00000000..d85a56f8
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,14 @@
+check_PROGRAMS = rt_init rscript_parse
+TESTS = $(check_PROGRAMS)
+
+test_files = testbench.h runtime-dummy.c
+
+rt_init_SOURCES = rt-init.c $(test_files)
+rt_init_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags) $(rsrt_cflags)
+rt_init_LDADD = $(rsrt_libs) $(zlib_libs) $(pthreads_libs)
+rt_init_LDFLAGS = -export-dynamic
+
+rscript_parse_SOURCES = rscript-parse.c $(test_files)
+rscript_parse_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags) $(rsrt_cflags)
+rscript_parse_LDADD = $(rsrt_libs) $(zlib_libs) $(pthreads_libs)
+rscript_parse_LDFLAGS = -export-dynamic