summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-04-07 12:42:41 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-04-07 12:42:41 +0200
commit2cd132eebb84dbcffcf0c20b9354c14f797c29cd (patch)
tree8bf071c79b8d274179884113cb12ac4ce1328847 /tests/Makefile.am
parent23a3fdb094cd992b2081db014d583b975c03ca57 (diff)
downloadrsyslog-2cd132eebb84dbcffcf0c20b9354c14f797c29cd.tar.gz
rsyslog-2cd132eebb84dbcffcf0c20b9354c14f797c29cd.tar.xz
rsyslog-2cd132eebb84dbcffcf0c20b9354c14f797c29cd.zip
enhanced nettester tool so that it re-uses it's callers environment
this enables us to work with the "usual" environment tweaks (for debugging and other purposes), without the need for any special handling in nettester itself
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7ca40766..53ca9cb0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
if ENABLE_TESTBENCH
TESTRUNS = rt_init rscript
-check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq msleep
+check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq msleep randomgen
TESTS = $(TESTRUNS) cfg.sh \
validation-run.sh \
imtcp-multiport.sh \
@@ -24,6 +24,7 @@ TESTS = $(TESTRUNS) cfg.sh \
dynfile_invld_sync.sh \
dynfile_invalid2.sh \
complex1.sh \
+ random.sh \
queue-persist.sh \
pipeaction.sh
execonlyonce.sh \
@@ -180,6 +181,8 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/gzipwr_large_dynfile.conf \
complex1.sh \
testsuites/complex1.conf \
+ random.sh \
+ testsuites/random.conf \
dynfile_invld_async.sh \
dynfile_invld_sync.sh \
dynfile_cachemiss.sh \
@@ -204,6 +207,9 @@ chkseq_SOURCES = chkseq.c
tcpflood_SOURCES = tcpflood.c
tcpflood_LDADD = $(SOL_LIBS)
+randomgen_SOURCES = randomgen.c
+randomgen_LDADD = $(SOL_LIBS)
+
nettester_SOURCES = nettester.c getline.c
nettester_LDADD = $(SOL_LIBS)