summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-03-26 17:48:59 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-26 17:48:59 +0100
commit0be199af6cc2cd9a9acb96e97e1cd061affaa6d9 (patch)
tree90366ffc1e2cb918eab2e6659581b1f5024db87e /tests/Makefile.am
parent5103c912eeb8c0d410f641a971d3687a02c8c02b (diff)
downloadrsyslog-0be199af6cc2cd9a9acb96e97e1cd061affaa6d9.tar.gz
rsyslog-0be199af6cc2cd9a9acb96e97e1cd061affaa6d9.tar.xz
rsyslog-0be199af6cc2cd9a9acb96e97e1cd061affaa6d9.zip
initial parser testing suite added
integrated tcl test script into autotools make check, created a few test cases based a real-world sample and samples from RFC3164 and 5424.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 384afd4e..225f087f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,8 +1,5 @@
-#AUTOMAKE_OPTIONS=dejagnu
-#DEJATOOL=Rainer
-
check_PROGRAMS = rt_init rscript
-TESTS = $(check_PROGRAMS) cfg.sh
+TESTS = $(check_PROGRAMS) cfg.sh parsertest
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
#TESTS = $(check_PROGRAMS)
@@ -19,7 +16,10 @@ EXTRA_DIST=1.rstest 2.rstest 3.rstest err1.rstest \
cfg4.testin \
DevNull.cfgtest \
err1.rstest \
- NoExistFile.cfgtest
+ NoExistFile.cfgtest \
+ parsertest
+ parser.tcl
+ testruns/*.parser1
rt_init_SOURCES = rt-init.c $(test_files)
rt_init_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)