summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-06-04 09:57:45 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-06-04 09:57:45 +0200
commit58e707b441aea88cd318762e6968e1db1211f949 (patch)
tree80271dac627000d5afed047a6372d633dd3fd068 /tests/Makefile.am
parent4f742a8e32c43dc9b514ceaf80f4d17e697dfdf6 (diff)
downloadrsyslog-58e707b441aea88cd318762e6968e1db1211f949.tar.gz
rsyslog-58e707b441aea88cd318762e6968e1db1211f949.tar.xz
rsyslog-58e707b441aea88cd318762e6968e1db1211f949.zip
backported some of the v5 testbench
this permits us to keep a persistent test environment between v4 and v5, most importantly using the same tools. As far as the actual tests are concerned, some had issues. I had no time to check if that was an issue with the test or an actual issue with the v3/4 engine. Will do that at some later stage.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am26
1 files changed, 20 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 402c1d83..a95139f2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,8 +1,13 @@
if ENABLE_TESTBENCH
TESTRUNS = rt_init rscript
check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
-TESTS = $(TESTRUNS) cfg.sh manytcp.sh diskqueue.sh imtcp-multiport.sh queue-persist.sh \
- validation-run.sh
+TESTS = $(TESTRUNS) cfg.sh \
+ validation-run.sh \
+ imtcp-multiport.sh \
+ diskqueue.sh \
+ manytcp.sh \
+ queue-persist.sh
+
if ENABLE_OMSTDOUT
TESTS += omod-if-array.sh parsertest.sh inputname.sh fieldtest.sh
endif
@@ -32,25 +37,32 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
err1.rstest \
NoExistFile.cfgtest \
testsuites/parse1.conf \
+ testsuites/field1.conf \
testsuites/1.parse1 \
- testsuites/rfc3164.parse1 \
+ testsuites/2.parse1 \
+ testsuites/3.parse1 \
+ testsuites/date1.parse1 \
+ testsuites/date2.parse1 \
+ testsuites/date3.parse1 \
+ testsuites/date4.parse1 \
+ testsuites/date5.parse1 \
+ testsuites/rfc3164.parse1 \
testsuites/rfc5424-1.parse1 \
testsuites/rfc5424-2.parse1 \
testsuites/rfc5424-3.parse1 \
testsuites/rfc5424-4.parse1 \
testsuites/omod-if-array.conf \
testsuites/1.omod-if-array \
+ testsuites/1.field1 \
killrsyslog.sh \
parsertest.sh \
+ fieldtest.sh \
diskqueue.sh \
testsuites/diskqueue.conf \
imtcp-multiport.sh \
testsuites/imtcp-multiport.conf \
manytcp.sh \
testsuites/manytcp.conf \
- fieldtest.sh \
- testsuites/field1.conf \
- testsuites/1.field1 \
inputname.sh \
testsuites/inputname_imtcp.conf \
testsuites/1.inputname_imtcp_12514 \
@@ -58,6 +70,8 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/1.inputname_imtcp_12516 \
omod-if-array.sh \
diag.sh \
+ daqueue-persist.sh \
+ daqueue-persist-drvr.sh \
testsuites/diag-common.conf \
queue-persist.sh \
queue-persist-drvr.sh \