summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-04-21 16:55:09 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-04-21 16:55:09 +0200
commit9e99fa5812d9653547327eafd640dc60277c89dd (patch)
treeae739ed79f1efe0d70de6a8c99515ae15b6e2960 /tests/Makefile.am
parent88caccecf8dd8beaf46915df05241a44f7d635f6 (diff)
parentaa43d7f83125f20f8efdf4152bdd9a09e7a81495 (diff)
downloadrsyslog-9e99fa5812d9653547327eafd640dc60277c89dd.tar.gz
rsyslog-9e99fa5812d9653547327eafd640dc60277c89dd.tar.xz
rsyslog-9e99fa5812d9653547327eafd640dc60277c89dd.zip
Merge branch 'nextmaster'
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ab1c5a62..0f4cbce1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
TESTRUNS = rt_init rscript
-check_PROGRAMS = $(TESTRUNS) ourtail udptester
-TESTS = $(TESTRUNS) cfg.sh parsertest.sh omod-if-array.sh
+check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
+TESTS = $(TESTRUNS) cfg.sh parsertest.sh omod-if-array.sh manytcp.sh diskqueue.sh
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
DISTCLEANFILES=rsyslog.pid
test_files = testbench.h runtime-dummy.c
@@ -27,13 +27,21 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/omod-if-array.conf \
testsuites/1.omod-if-array \
parsertest.sh \
+ diskqueue.sh \
+ testsuites/diskqueue.conf \
+ manytcp.sh \
+ testsuites/manytcp.conf \
omod-if-array.sh \
cfg.sh
ourtail_SOURCES = ourtail.c
+chkseq_SOURCES = chkseq.c
-udptester_SOURCES = udptester.c getline.c
-udptester_LDADD = $(SOL_LIBS)
+tcpflood_SOURCES = tcpflood.c
+tcpflood_LDADD = $(SOL_LIBS)
+
+nettester_SOURCES = nettester.c getline.c
+nettester_LDADD = $(SOL_LIBS)
rt_init_SOURCES = rt-init.c $(test_files)
rt_init_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)